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Introduction

Informatics is complex

– Information

• Gaining

• Processing

• Storing

• Forwarding

https://image.slidesharecdn.com/bigdatasolutionsoncloudthewayforward-150804050417-lva1-app6892/95/big-data-solutions-on-
cloud-the-way-forward-3-638.jpg?cb=1438664749



Introduction

The concept of information

• Information is a basic concept of informatics.
There are a lot of definitions in everyday life which have it
in common that information decreases uncertainty and 
has a novelty content, conveys new knowledge.

• The forms of information can be different. Words made up
of letters and sentences with punctuation marks mean
information in a book . A mark given for an oral
presentation is information in the form of a number. 
Colours and different lines in a map also convey
information.



Introduction

Unit of information

• BIT: Short for binary digit, the smallest unit of 
information on a machine.  
A single bit can hold only one of two values: 0 or 1. 
More meaningful information is obtainedby combining 
consecutive bits into larger units.

• BYTE: Abbreviation for binary term, a unit of storage 
capable of holding a single character.

Remark: Graphics are also often described by the number of bits used to 
represent each dot. The 1-bit image is monochrome; an 8-bit image supports 
256 colors or grayscales; and a 24- or 32-bitgraphic supports true color.
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Introduction

Unit of information

• Nibble:
A group of four bits, or half a byte, is sometimes called a 
nibble or nybble. This unit is most often used in the 
context of hexadecimal number representations, since a 
nibble has the same amount of information as one 
hexadecimal digit.

• Crumb:
A pair of two bits or a quarter byte was called a crumb, 
often used in early 8-bit computing (see Atari 2600, ZX 
Spectrum). 
It is now largely defunct. 





Introduction

• Data is actually recorded knowledge, a sequence of 
signals used for representing information. All the 
signals which are necessary for processing or are
created during it, or appear as its result are considered
data. It may not have a novelty as it depends on who
receives it.



The term “BIG DATA” refers to data that is so large, fast or complex that it’s difficult 
or impossible to process using traditional methods. The act of accessing and storing 
large amounts of information for analytics has been around a long time. But the 
concept of big data gained momentum in the early 2000s when industry analyst Doug 
Laney articulated the now-mainstream definition of big data as the three V’s:

• Volume: Organizations collect data from a variety of sources, including business 
transactions, smart (IoT) devices, industrial equipment, videos, social media and 
more. In the past, storing it would have been a problem – but cheaper storage on 
platforms like data lakes and Hadoop have eased the burden.

• Velocity: With the growth in the Internet of Things, data streams in to businesses 
at an unprecedented speed and must be handled in a timely manner. RFID tags, 
sensors and smart meters are driving the need to deal with these torrents of data 
in near-real time.

• Variety: Data comes in all types of formats – from structured, numeric data in 
traditional databases to unstructured text documents, emails, videos, audios, 
stock ticker data and financial transactions.

Introduction



BIG DATA



Introduction

The 6 revolutions of communication:

• 1. The revolution of speech which is actually the 
revolution of becoming a human.

• 2. The revolution of writing /information storing is 
realized, information becomes independent of human 
memory/ - the appearance of phonetic writing

• 3. The revolution of printing press/ the mass
dissemination of information is realized/, This
completed the revolution of writing, and with its help
written texts could reach masses.



Introduction

• 4. The revolution of telecommunication/ distances
could become bridgeable
The revolution of electronic communication devices –
telegraph, telephone, radio, television – which is 
intertwined with the revolution of the information
processing of electronic computers. Due to this, 
information connections span through the globe.



Introduction
• 5. The revolution of computer/electronic information

processing
With the appearance of the computer a new type of 
communication was created. Besides human-human 
dialogue the human-machine dialogue appeared. New 
opportunities of information storing and processing opened
up with the help of the computer. 

Internet – the appearance of  computer networks, more 
specifically of the interconnection of open systems. Internet, 
which is the determinate corner stone of the information
society, is built on a new technology which connects
informatics and telecommunication, changes the operation
of the society, social communication. 



6. The revolution of "Cognitive infocommunications (CogInfoCom)
The Cognitive Infocommunication investigates the link between
the research areas of infocommunications and the cognitive
sciences, as well as the various engineering applications which
have emerged as the synergic combination of these sciences. The
primary goal of CogInfoCom is to provide a systematic view of
how cognitive processes can co-evolve with infocommunications
devices so that the capabilities of the human brain may not only
be extended through these devices, irrespective of geographical
distance, but may also interact with the capabilities of any
artificially cognitive system. This merging and extension of
cognitive capabilities is targeted towards engineering
applications in which artificial and/or natural cognitive systems
are enabled to work together more effectively."

Introduction



Introduction

From the perspective of global communication, 
Internet has played the most important role lately
and as for the future, this new medium has a key
role.

Future Internet 2018, 10(8), 68; https://doi.org/10.3390/fi10080068

https://doi.org/10.3390/fi10080068




The way of information

• The creation of information is a key process in 
informatics.

The information source, the sender prepares the
statement/message with a kind of method, that is, it
transforms the information to be communicated into
signals. 
Then he sends it to the addressee, and he uses a 
transmitting medium for this. Information has to be 
formed into a series of signals during coding where the 
medium is suitable for transmitting these. The medium
„is not always noticed”, although it has a necessary
role.



The way of information

• After receiving the statement, the addressee tries to 
get the information from the statement, to interpret
the signals.
In informatics the sender is called transmitter, the 
addressee is called receiver. Creating the statement
is coding, and getting the information is decoding.

The term for transmitting medium is: 
transmission channel.





The way of information

The role of  the channel is to send the coded
statement/message, the signals from the transmitter to the 
receiver.
But environment also influences this channel. Effects
coming from the environment can disturb transmission, so
the signals to be transmitted can be distorted, can even get
lost. These disturbing effects are called noise. In reality not
only single-step coding and decoding happen.

Sender Coder Channel Decoder Receiver

Environment

InformationInformation SignalSignal

Noise



Introduction

• Information technique

– Informatics from the side of technical device

• Computing

– It deals with the devices of automated data
processing



Computing

• Computing is a theoretical and applied technical
science dealing with the devices of automated
data processing and their usage in different fields
(e.g. building a computer and programming it).

– Computing/Informatics is in close connection
with informatics, a science dealing with
investigating the creation, 
forwarding/transmission, processing and 
utilization of information.



Generations of computers
• Zero generation computers – mechanical machines

(John Atanastof’s machine –captors,  DRAM, MARK I. – relay)
• The first computers used vacuum tubes for circuitry and magnetic 

drums for memory. (ENIAC-Elektronic Numerical Integrator And 
Computer) 

• Second generation computers - Transistors (1961 - PDP-1,)

• Third generation computers – Integrated circuit (1965-1980 –Transistors 

were miniaturized and placed on siliconchips, called semiconductors.)

• Fourth generation computers – The microprocessor brought the fourth 

generation of computers, as thousands of integrated circuits were built onto 

a single silicon chip, from the central processing unit and memory to 

I/O controls—on a single chip.

• Fifth generation computers– AI -Memristors



The history of computers

Zero generation

• Calculation from the beginnings

– People have sought since the earliest times to make
devices which make calculation easier and faster.

The first calculating devices were pebbles, pieces of 
wood, knots tied on ropes, trees, signs carved on the 
ground.

These devices were suitable not only for calculation
but also for preserving the result of calculation.



The history of computers
Different nations used different
numeral systems and digits
(signals).

The Sumers, then the
Babylonians used the
sexagesimal numeral system. 
The subdivision of time and 
angles originate from here.

The Chinese calculated using
sticks made of ivory.

The Egyptians indicated
numbers with the help of 
hieroglyphs.

Egyptian number hieroglyphs

Babilonian numbers

Fönitian number hieroglyphs

Sekler-Hungarian runic numbers

Aztec number writing – „knot numbers”

„feather” numbers

Some hieroglyoh number writing



The history of computers

New devices were needed in favour of wider
spread. The first one was the stone tablet.
Summation and subtraction of large numbers
could be made easily by moving pebbles to and
fro.



The history of computers

This device was perfected by the Romans and 
they created the calculus..  The word calculator
evolved from the Latin equivalent of the word
pebble throughout history. Its meaning is still a 
device helping calculation.

Interestingly, the word digital derives from the 
Latin word digitus (finger), and the word
computer from the word computare (carving on
runic wood). 



The history of computers

Devices similar to calculus were also developed
in China and Japan (independently from each
other). The Chinese called it Suan Pan, the 
Japanese soroban.



The history of computers

• The most significant step in the development
of the concept of numbers was the 
appearance of place value.



The history of computers

In the 17th century, several machines were made which
were able to make basic operations.
There was a great need for these, among others when
making nautical and astronomical maps. 

Wilhelm Schikard (1592-1635)  astronomer professor  
was an outstanding figure of this, his machince could
both divide and multiply. It made calculations in a 
mechanical way using the combination of rods, cog
wheels and an automatic transmission-making
mechanism.  



The history of computers

Sketches from his letter to 
Kepler. 
The world learnt about the 
existence of the calculator while
processing the Kepler-heritage
in 1957, when Hammer, the 
Kepler-researcher published the
letters and sketches he had 
found.



The history of computers

At the same time, Napier, a Scottish baron, 
developed the concept of logarithm, facilitating
the deduction of multiplication to summation.



The history of computers

He himself also made a computer with which it was 
possible to multiply ten-digit numbers within a few
seconds.

The English Morland and the French Pascal
(1623-1662) made a similar machine. 

Pascal’s machine was the first computer „produced in 
series”. 7 pieces were made of these.



The history of computers

He wanted to help his father - who needed to make loads of 
calculations of tax collection - with the machine converted
from clockworks.  

This machine was further developed by Leibniz
(1646-1716) the German mathematician.

His invention was the first one which directly
made divisions and multiplications.

It made subtraction without supplementary operation. He 
took advantage of the fact, that multiplication can be 
deducted to summation.



The history of computers

It could achieve that basic operations could be 
made even ten times, hundred times faster. 

It was attributed to him that computers do not
use the decimal but the binary numeral system.



The history of computers
Babbage (1791-1871), the English 
mathematician astronomer was 
one of the great figures of the 19th 
century. 
He received a permit to build the 
Difference Engine,

the machine will be able to make
tables. He was not able to build
it after trying several times and 
in 1833 he finally gave up his
plans.



The history of computers

Georg Scheutz, Swedish printer (1785-1873) built the 
difference engine using Babbage’s plans and in 1854 he 
presented it in London. The machine received a gold
medal at the First Paris International Exposition in 
1855.

Joseph Jacquard (1752-1834), the builder of the analytic
machine, developed the automation of weaving fabric
on the loom. The key of his method was the application
of a series of cards on which holes were punched so that 
they composed the required design. 



The history of computers

The analytic machine was almost perfectly analog.
The machine consisted of two parts:

- Store/memory, where the variables were placed
with which operations had to be made and sums
created as the result of other operations were also
stored here.

- Mill, where sums were put in with which some
kind of operations had to be made.



The history of computers

Although due to its complexity he could never build this
machine, he is considered the spiritual father of 
computing/informatics because of the ideas developed
during planning. 



The history of computers

Hermann Hollerich (1860-1929) the  Department of 
Homeland Security of the USA used his punched card
machine at the census in 1890.

He made one card for each inhabitant which contained
if the person was male or female, white or black, native
or foreigner, etc.

He constructed a machine to punch
these cards and a simple device to 
categorize the cards.



The history of computers

The first generation

• After the invention of the vacuum tube in 1906, it could be 
produced in a technically applicable form in the 1930s. Its
main advantage was speed. 

• The computer called ENIAC was made in 1946. 18 thousand
vacuum tubes were used for building it. The 30-ton 
structure consumed 120 – 150 kW electrical energy. 
The input and output of data happened with the help of 
punch cards.
It was about thousand times faster than its predecessors.



The history of computers

ENIAC



The history of computers

- ENIAC was followed by EDVAC which was the first program-
controlled, digital universal machine.

- Its basic principles were developed by János Neumann (1903-
1957). 

These principles were the following: 
- The computer has to be completely electronic, with a separate

controller and executive/performing unit. 

- It has to use binary numeral system.

- Data and programmes have to be placed in the same interior
store, the memory. 

- The computer has to be universal.

The principles developed by Neumann are guidelines even today.



The history of computers

Second generation
- The era between the years of 1959 – 65.

The invention of transistor facilitated the emergence of the 
new generation. It meant a huge size reduction, at the same
time their energy consumption also decreased significantly. 
The speed of operation also multiplied.

- The early computers produced by IBM – although consisted
of 160,000 transistors – made one million operations per 
second. It meant a six thousand fold increase in speed
compared to tubular machines.

The reliability of machines increased to about thousandfold.



The history of computers

Third generation

- The era between the years of 1965 – 71.

- Due to the integrated circuit technique, several
thousand circuit elements can be placed in a  single
semiconductor chip per square centimeter.

- The size was further reduced and speed increased.

- Byte- structure and input-output processor appeared.

- Computers could already make several operations
parallelly.



The history of computers

- The integrated circuits further decreased the price, 
size and the number of malfunctions of computers.

- This further increased the demand for computers:
by the beginning of the 1970s more than 100,000 
large computers and also more than 100,000 
minicomputers were put into operation

- Today more than 5 million transistors are in 
processors, none of which go wrong during
operation.



The history of computers

- The operation system appeared.

- The first high-level languages were created.
ALGOL, BASIC and COBOL were outstanding.



The history of computers

Fourth generation: the microprocessor

The complete CPU created in a single semiconductor
element is called microprocessor which is placed in a single
integrated circuit case. 

The INTEL company announced the creation of the
microprocessor in 1971, the unit marked 8008. 

The appearance of microprocessors made it possible that
computers could enter everyday life.



The history of computers
Since the appearance of the microprocessor, 
the performance of computers – not only PCs –
doubles every second year, this is Moore’s law.

Gordon Moore’s article was published in the
Electronics Magazine, which predicted that the
number of integrated circuits will double every
year, with continuous cost reduction. 

The prediction which became well-known as Moore’s Law 
made the spread of technology possible in the whole world
and by today it is fundamental for fast technological changes. 

Moore reconsidered his prediction in 1975 and stated that
the number of transistors on chips will double
approximately every second year.



The history of computers

Besides predicting the increase of the complextiy of the chip 
(which is measured with the number of transistors on one
computer chip), Moore’s Law also suggests the reduction of 
costs.
As the silicium-based „spare parts” and platform components
continuously increase performance, the manufacturing cost
can exponentially decrease, so it can be integrated in our
everyday life in larger quantity, more dynamically and without
problems.



The history of computers
The fifth generation the future

- The most significant developments tend to the application of
microprocessors suitable for parallel operation,  but
minituarization also has an important role.
The ultimate aim of developments is the creation of artificial
intelligence. 

- The practical application of parallel processing would mean a 
significant progress, which means that several circuits solve
different tasks at the same time. With its help, even the
imitation of human thinking would become possible.

- Investigations are carried out to develop optical computers. 
Instead of electrons, light impulses will carry information in
these.



What is MEMRISTOR?

• Fourth fundamental circuit element

• Passive element

• Two terminal device



History of Memristor

• He mathematically postulated that 
based on the relations between the
four fundamental circuit variables 
and the symmetry, there should 
exist another circuit element that 
relates the charge and flux

1971: Leon Chua*, From 
University of California 
Berkeley

2008: HP – memristor: 3nm

2014: „The Machine project”



4 basic passive circuit elements



Definition of Memristor

• MEMRISZTOR is a semiconductor whose resistance
varies as a function of flux and charge. This allows it
to remember what has passed through the circuit.

• Memristor is a portmanteau of “memory resistor”. 
It is a passive device with two terminals, where the
magnetic flux is related to the amount of passed 
electric charge through the device.

• Symbol of a memristor: 

• Characterised by MEMRISTANCE:

• Unit: Ω (ohm)                     



Memristor definition



Memristor opportunities



Memristor Fabrication



Molecular and Ionic Thin Film Memristors



Molecular and Ionic Thin Film Memristors



Molecular and Ionic Thin Film Memristors



Molecular and Ionic Thin Film Memristors



Spin based and Magnetic Memristors



Spin based and Magnetic Memristors



Ferroelectric Memristors



Potential applications



Classification of computers

• Two main types
– Analog

– Digital computer

• Analog computers deal with the mathematical
description of physical phenomena.
Can be beneficially used e.g. for solving bioligical tasks, 
their accuracy and speed is limited.

• Digital computers divide, translate tasks into discrete
values (numbers, digits), and the prescribed operations
are made on these.



Classification of computers

• Personal computer (PC) 

– The well-known desktop computer. It is able to run operation
systems and users‘ programmes in itself. Connected in a 
network, it can share its storing, processing and printing  
resources.

• Notebook

– The portable version of desktop computer.

• Tablet PC

– The hand-held version of  notebook.



Classification of computers
How and what for people use the iPad? Briefly we can
summarize general experiences, that iPad and other
similar machines are primarily the most 
suitable for passive media consumption
(reading, watching videos) and 
also for gaming.

• PDA/hand-held computer
It is a miniaturized computer, 
usually runs with a simplified
operating system of the Microsoft, 
suitable for limited tasks.



Classification of computers

• PNA (Portable Navigation Assistant)

A device particularly made for
navigation, usually suitable also for
playing MP3, MP4.

• Multimedia players
MP3, (MP4), MP5 



Classification of computers
• Network computers:

Their primary task is recording data, providing information.

Terminals:

–A working station consisting of a monitor and keyboard. 
Usually used connected in network, for low computational
tasks. Terminals use the resources of servers.

We distinguish:

• Intelligent terminal:

An input-output device connected to the central computer 
which is also suitable for preparing, processing data.



Classification of computers

• Smart terminal:

It provides functions similar to intelligent terminals, but
has fewer local resources. 

• Simple-minded terminal:

An input-output device connected to the central
computer which is suitable exclusively for contacting the
central computer. It does not have its own processor, 
memory or mass storage, usually consists of one monitor 
and an input unit.



Classification of computers



Classification of computers

• Large computers

– Supercomputer

– Mainframe

– Minicomputer



Classification of computers

• Supercomputer

– The fastest and most expensive type of
computer

–Target computers built individually, 
which are used for the fastest possible
execution of a  given, usually high
computational programme.

–Field of use:

• making weather forecasts, 

• simulating nuclear explosions,

•making the effects of top-quality
animations of movies



Classification of computers

• Mainframe

– A huge computer which includes the performance of loads
of desktop computers. It is usually used as a network server, 
and for industrial calculations.

– Machine used for serving several users connected through
terminals, for processing a large amount of data

– Processing is made on the central machine

– Are able to run many programmes fast at one time

– Its use is typical in a corporate environment, it handles the
data bases, correspondence of the given company

– Its cost, depending on the performance demand can even
approximate the manufacturing costs of a supercomputer





Classification of computers
•Minicomputer

–Similar to mainframe computers concerning their tasks and 
mode of access, but its performance is smaller.

–Used for data processing in small and medium-sized
companies where serving maximum 100-200 users is 
needed.

–Lower performance, significantly cheaper than mainframe
systems



Computer software can be put into categories based on common 
function, type, or field of use. There are three broad classifications:

• Application software is the general designation of computer 
programs for performing tasks. Application software may be 
general purpose (word processing, web browsers, etc.) or have a 
specific purpose (accounting, truck scheduling, etc.). 
Application software contrasts with system software.

• System software is a generic term referring to the computer 
programs used to start and run computer systems including 
diverse application software and networks.

• Computer programming tools, such as compilers and linker, are 
used to translate and combine computer program source code 
and libraries into executable RAMs (programs that will belong to 
one of the three said)

Classification of softwares



Classification of softwares

• free software, 

• open source software, 

• public domain software, 

• copylefted software, 

• noncopylefted free 
software, 

• lax permissive licensed
software, 

• GPL-covered software, 

• the GNU operating system, 

• GNU programs, 

• GNU software, 

• FSF-copyrighted GNU 
software, 

• nonfree software, 

• proprietary software, 

• freeware, 

• shareware, 

• private software and 

• commercial software.

Copyright status



Free software

• Free software is software that comes with
permission for anyone to use, copy and
distribute, either verbatim or with modifications,
either gratis or for a fee. In particular, this means
that source code must be available. "If it's not
source, it's not software." If a program is free,
then it can potentially be included in a free
operating system such as GNU, or free versions of
the Linux system.

Classification of softwares



Open source software

• Open source software is software with its source code
made available under a certain license to its licensees.
It can be used and disseminated at any point, the
source code is open and can be modified as required.
The one condition with this type of software is that
when changes are made users should make these
changes known to others. One of the key
characteristics of open source software is that it is the
shared intellectual property of all developers and
users. The Linux operating system is one of the best
known examples of a collection of open source
software

Classification of softwares



Copylefted software

• Copylefted software is free software whose distribution terms ensure that all
copies of all versions carry more or less the same distribution terms. This
means, for instance, that copyleft licenses generally disallow others to add
additional requirements to the software (though a limited set of safe added
requirements can be allowed) and require making source code available. This
shields the program, and its modified versions, from some of the common
ways of making a program proprietary. Some copyleft licenses block other
means of turning software proprietary.

Copyleft is a general concept. Copylefting an actual program requires a
specific set of distribution terms. Different copyleft licenses are usually
“incompatible” due to varying terms, which makes it illegal to merge the code
using one license with the code using the other license. If two pieces of
software use the same license, they are generally mergeable.

Classification of softwares



Non-copylefted free software

• Noncopylefted free software comes from the
author with permission to redistribute and
modify and to add license restrictions.
The X Window System illustrates this approach.
The X Consortium releases X11 with
distribution terms that make it noncopylefted
free software.

Classification of softwares



Shareware

• Shareware is software that comes with
permission to redistribute copies, but says that
anyone who continues to use a copy is required
to pay. Shareware is not free software, or even
semi-free. For most shareware, source code is not
available; thus, the program cannot be modified.
Shareware does not come with permission to
make a copy and install it without paying a
license fee, including for nonprofit activity.

Classification of softwares



Freeware

• Like shareware, freeware is software available for
download and distribution without any initial
payment. Freeware never has an associated fee.
Things like minor program updates and small
games are commonly distributed as freeware.
Though freeware is cost free, it is copyrighted, so
other people can't market the software as their
own.

Classification of softwares



Grouping Operating Systems by dimensions

1D Operation System – DOS

2D Operation System – Windows

3D Operation System 

- MaxWhere



In Word, you can customize or choose
predefined margin settings. Word
automatically sets a one-inch page margin
around each page.

You also can set margins for facing pages,
allow extra margin space to allow for
document binding, and change how
margins are measured.

1. Select Layout > Margins. 

2. Select the margin configuration you 
want.
If you don't see the configuration you 
want, select Custom Margins to define 
your own margins

Using Microsoft Word program



Using Microsoft Word program

Follow these steps to add and format text in Word.

• Add text

– Place the cursor where you want to add the text.

– Start typing.

• Format text

– Select the text you want to format.

– Select an option to change the font, font size, font color, or make the text 
bold, italics, or underline etc.



Insert Pictures:
• Select Insert > Pictures for a picture on your PC.

• Select Insert > Online Pictures for a picture that's on the web.

Resize or move pictus:
• To resize a picture, select the picture and drag a corner 

handle.

• To wrap text around a picture, select the picture, and then 
select a wrapping option.

Using Microsoft Word program



Insert a table

• For a basic table, click
Insert > Table and move the
cursor over the grid until you
highlight the number of
columns and rows you want.

• For a larger table, or to
customize a table, select
Insert > Table > Insert Table.

Using Microsoft Word program



Equations
Office has equations that you
can readily insert into your
documents. If the Office built-
in equations don’t meet your
needs, you can edit, change the
existing equation, or write your
own equation from scratch.

• Choose 
Insert > Equation 
and choose the 
equation you want 
from the gallery.

Using Microsoft Word program



Insert footnotes and endnotes
Footnotes appear at the bottom of the page
and endnotes come at the end of the
document. A number or symbol on the
footnote or endnote matches up with a
reference mark in the document.

1. Click where you want to reference to the 
footnote or endnote.

2. On the References tab, select Insert 
Footnote or Insert Endnote.

3. Enter what you want in the footnote or 
endnote.

4. Return to your place in the document by 
double-clicking the number or symbol at 
the beginning of the note.
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Create a bibliography, 
citations, and references

• Put your cursor at the end 
of the text you want to cite.

• Go to References >  Style, 
and choose a citation style.

On the References tab choose 
a citation style from the Style 
list.

• Select Insert Citation
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• Choose Add New Source and 
fill out the information about 
your source.

Once you've added a source to 
your list, you can cite it again:

– Put your cursor at the end of 
the text you want to cite.

– Go to References > Insert 
Citation, and choose the 
source you are citing.
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Create a bibliography

With cited sources in your document, you're 
ready to create a bibliography.

– Put your cursor where you want the bibliography.

– Go to References > Bibliography, and choose a 
format.

Remark: If you cite a new source, add it to the 
bibliography by clicking anywhere in the 
bibliography and selecting Update Citations and 
Bibliography.
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Share a document
When you share your document with others and give them
permission to edit, everyone's changes are made in the same
document.

1. In the top right corner, above the ribbon, click Share.

2. Save your document in OneDrive, if it's not already there.

3. Enter email addresses of the people you want to share with, and 
make choices for permission you want to allow.

4. Type a message if you want, and click Send.

Remark: The people you're sharing with will get mail from you, with 
a link to your document.
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• When someone shares a Word
document with you, the email you
receive includes a link that opens the
document in your web browser: in
Word for the web. Select Edit
Document > Edit in Browser.

• If anyone else is working on the
document, you'll see their presence
and the changes they're making. We
call this coauthoring, or real-time
collaboration.

• From here, if you'd rather work in
your Word app, switch from Editing
to Open in Desktop App, near the
top of the window.

Using Microsoft Word program
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With PowerPoint on your PC, Mac, or mobile device, you can:

– Create presentations from scratch or a template.

– Add text, images, art, and videos.

– Select a professional design with PowerPoint Designer.

– Add transitions, animations, and cinematic motion.

– Save to OneDrive, to get to your presentations from your 
computer, tablet, or phone.

– Share your work and work with others, wherever they 
are.
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Slide Master
• When you want all your slides to 

contain the same fonts and images 
(such as logos), you can make those 
changes in one place—the Slide 
Master, and they'll be applied to all 
your slides. To open Slide Master 
view, on the View tab, select Slide 
Master:

• The master slide is the top slide in 
the thumbnail pane on the left side 
of the window. The related layout 
masters appear just below the slide 
master:
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• When you edit the slide master, all slides that are based on
that master will contain those changes. However, the
majority of changes that you make will most likely be to the
layout masters related to the master.

• When you make changes to layout masters and the slide
master in Slide Master view, other people working in your
presentation (in Normal view) can’t accidentally delete or
edit what you’ve done.
Conversely, if you're working in Normal view and find that
you're unable to edit an element on a slide (such as, "why
can't I remove this picture?") it may be because the thing
you're trying to change is defined on the slide master or a
layout master. To edit that thing, you must switch to Slide
Master view.
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Themes

• A theme is a palette of colors, fonts, and special effects (like shadows,
reflections, 3-D effects, and more) that complement one another. A
skilled designer created each theme in PowerPoint. We make those
pre-designed themes available to you on the Design tab in Normal view.

• Every theme you use in your presentation includes a slide master and a
related set of layouts. If you use more than one theme in your
presentation, you’ll have more than one slide master and multiple sets
of layouts.
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Slide Layouts

• You change and manage slide layouts in Slide
Master view. Every theme has a several slide
layouts. You choose the layouts that best
match your slide content; some are better for
text and some are better for graphics.

• In Normal view, you’ll apply the layouts to
your slides

• Each slide layout is set up differently — with
different types of placeholders in different
locations on each layout.

• Every slide master has a related slide layout
called Title Slide Layout, and each theme
arranges the text and other object
placeholders for that layout differently, with
different colors, fonts and effects. The
following pictures contrast the title slide
layouts for two themes: first the Basis theme
and then the Integral theme.
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Slide transition

A slide transition is the visual effect that occurs when you move
from one slide to the next during a presentation. You can
control the speed, add sound, and customize the look of
transition effects.

• Select the slide you want to add a transition to.

• Select the Transitions tab and choose a transition. Select a
transition to see a preview.

• Select Effect Options to choose the direction and nature of
the transition.

• Select Preview to see what the transition looks like.

Using Microsoft PowerPoint program
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Animate text or objects

• You can animate the text, pictures, shapes, 
tables, SmartArt graphics, and other objects in 
your PowerPoint presentation.

• Effects can make an object appear, disappear, 
or move. They can change an object's size or 
color.

Using Microsoft PowerPoint program
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Add animations to text, pictures, shapes, and more in your presentation:

1. Select the object or text you want to animate.
2. Select Animations and choose an animation.
3. Select Effect Options and choose an effect.

Manage animations and effects:

There are different ways to start animations in your presentation:
1. On Click: Start an animation when you click a slide.
2. With Previous: Play an animation at the same time as the previous 

animation in your sequence.
3. After Previous: Start an animation immediately after the previous one 

happens.
4. Duration: Lengthen or shorten an effect.
5. Delay: Add time before an effect runs.

Using Microsoft PowerPoint program
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Add more effects to an animation
• Select an object or text with an animation.
• Select Add Animation and choose one.

Change the order of animations
• Select an animation marker.
• Choose the option you want:

– Move Earlier: Make an animation appear earlier in the sequence.
– Move Later: Make an animation occur later in the sequence.

Add animation to grouped objects
You can add an animation to grouped objects, text, and more.
• Press Ctrl and select the objects you want.
• Select Format > Group > Group to group the objects together.
• Select Animations and choose an animation.

Using Microsoft PowerPoint program
Animations



Share a presentation by saving it to the cloud 
and sending it to others

• Select Share.

• Select where to save your presentation to the 
cloud.

• Choose a permission level.

• Select Apply.

• Enter names and a message.

• Select Send.

Using Microsoft PowerPoint program



Practice

You can find practical tasks in the network folder 
below:
O: (Tutors) \ Department Materials \ Electrical 
Networks \ Ildiko Horvath \ Tasks \ Microsoft 
Word or Microsoft PowerPoint 

Open the file and complete the task based on 
the template
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attention!
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